How to get rid of the logs of one specific output? (ouput exec)

Hi, Im using logstahs output exec and every time it runs, the output exec create a log like this:

[2020-08-27T16:56:40,756][INFO ][logstash.outputs.exec    ][my-pipeline][53bf2b...]

the problem is that are hundreds of logs per minute, and that quantity hide the logs of other pipelines.

Also, when Im working in an integration I run logstash with the command:

sudo /usr/share/logstash/bin/logstash --path.settings /etc/logstash

to watch the logs in real time, so all those logs are really a problem

is there a way to avoid that this output create logs?

If you are talking about it logging the output of the command then you can suppress that using the quiet option.

1 Like