How to handle logstash logs in ubuntu 18.04

i have couple of problem. The logstash document says logs saved in /var/log/logstash folder,
but in my case log is saved in /usr/share/logstash/log folder ? so why is that ?

Other problem i am having is ubuntu syslog size keep on increasing and when i check it contail full of logstash logs. so is there way to stop syslog accumulating syslog file ?

my syslog file size is currently 16G, 3 hours ago it was 12G

Check that you don't have debug turned on in you logstash.yml file and there may be a symbolic link from /var/log/logstash to /usr/share/logstash/log

no it is log.type info is enabled

please help

I have had similar "issues" with Elasticsearch. I ended up creating my own file so I could disable syslog logging.

Actually looks like that was only to change log level...

Is there any other way, rather than changing the log4j file?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.