How to mention credentials of shield for packetbeat?


(Akhilesh Anb) #1

I installed shield for authentication purpose. I have created a user. Now im unable to start the service packetbeat.

Can you tell me how to mention credentials in .yml file. or how to start packetbeat service with that shield user credentials.

/etc/init.d/packetbeat start . Its not starting , its giving an error :

output.go:64:
 ERR Fail to set _ttl mapping: ES returned an error: 401 Unauthorized publish.go:232: ERR Fail to initialize elasticsearch plugin as output: ES returned an error: 401 Unauthorized main.go:150: CRIT ES returned an error: 401 Unauthorized ...fail!

Help me @tudor


(Mark Walkom) #2

Try setting something like hosts: ["username/password@localhost:9200"].


(Akhilesh Anb) #3

I mentioned that line in .yml. Even though its giving me the same error.

Is there any way to mention credentials? Its very important to me @warkolm . Please help me to start packetbeat with shield credentials. Thanks in advance. :blush:


(Tanya Bragin) #4

Instructions are here:
https://www.elastic.co/guide/en/beats/packetbeat/current/_using_https_and_basic_authentication.html


(system) #5