How to sends logs from remote machine to Logstash or Elastic Search

Hi There,

I have installed Elasticsearch, Logstash, and Kibana (Elastic Stack) on Ubuntu 18.04 as suggested in the below article and everything configured correctly..

But I have installed metric beat on the remote windows server and configured the metricbeat .yaml files, started the service but while connecting to Logstah server from a remote windows machine within same network to sends system metric logs and but its not sending and giving error as an attached snapshot.

As listen Logstash & Elastic Search only listening localhost might be the caused this issue but tried to change it local to IP address but to able to change it. Can someone please guide me to get this done.

Basically I want to achieve this for each machine in my network..


Below is the metric.Yaml config file...

================================= Dashboards =================================

These settings control loading the sample dashboards to the Kibana index. Loading

the dashboards is disabled by default and can be enabled either by setting the

options here or by using the setup command.

setup.dashboards.enabled: true

=================================== Kibana ===================================

Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

This requires a Kibana endpoint configuration.


Kibana Host

Scheme and port can be left out and will be set to the default (http and 5601)

In case you specify and additional path, the scheme is required: http://localhost:5601/path

IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

host: ""

---------------------------- Elasticsearch Output ----------------------------


Array of hosts to connect to.

#hosts: ["localhost:9200"]

Protocol - either http (default) or https.

#protocol: "https"

Authentication credentials - either API key or username/password.

#api_key: "id:api_key"
#username: "elastic"
#password: "changeme"

------------------------------ Logstash Output -------------------------------


The Logstash hosts

hosts: [""]

You don't need Logstash. Just send to elasticsearch.

Thanks for your response, apericate it. But my elastic search only listening on localhost not Lan ip and due to thisetricbeat is not able to connect from remote machine.. Can you help me to fix it?

Hi Pankaj, I am also stuck at similar state. Did U find any solutin to Ur problem ?

Hi Sid,

I have figure it out this issue and able to resolve it by changing configuration in elastic config file, Please comment this setting with # then try to connect from remote machine it would be working fine.


Thanks Pankaj..I will check it out

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.