Http_compression Set 'compression_level' instead

"http_compression" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Set 'compression_level' instead.

Getting error after updating

compression_level expected one of [0, 1, 2, 3, 4, 5, 6, 7, 8, 9], got ["true"]

Updated to compression_level => 6

Now it does not like it for http

Unknown setting 'compression_level' for http