Http_max_content_length not enforced properly

(James) #1

Hi,
We have the following configuration variable set in a deployment:

http.max_content_length: "400mb"

but when indexing a document are seeing the error

Caused by: org.elasticsearch.client.ResponseException: POST https://d72ceeb814c740869fafde4e6a89c6d4.dev-eu.elastic.nomura.com:9243/_bulk: HTTP/1.1 413 Request Entity Too Large

Request Content-Length 242874783 exceeds the configured limit of 209715200

Looks like the deployment has a configured limit of 200mb despite what is set in the yaml. Wondering if the setting is not being enforced properly?

Additionally is there a way to check the http_max_content_length from within the deployment? Haven't found anything online so far.

Thanks,
James

(Alex Piggott) #2

The EC/E proxy places its own limit of 200MB on traffic. This limit is not currently configurable

This is in addition to any limit from max_content_length (which apart from the above is applied as you'd expect)

The v2 proxy that is currently being tested and will in due time (no ETA!) replace the current one does not have that limit

Alex

1 Like
How to update http.max_content_length in elastic cloud cluster
(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.