HTTP_Poller and Elasticsearch

Hi,

I am trying to query elasticsearch API with http_poller input but keep getting the beloved PKIX building path failed error. I've set the elasticsearch.yml on the node being queried to contain the following:

xpack.security.transport.ssl.client_authentication: optional
xpack.security.http.ssl.client_authentication: optional

The config that contains the http_poller input is pretty plain, it looks like this:

input {
    http_poller {
       urls => {
         url => "https://{{fqdn}}:9200"
       }
    schedule => { cron => "* * * * * UTC"}
  }
}


output {
  file {
    path => "output.json"
  }
}

I'm not sure what I'm doing wrong here? I thought setting the params I mentioned in the elasticsearch.yml file would cause ES to not require a client cert when queried but still use SSL.

Also interesting is that when i change the URL from https to http the connection is just simply rejected