I cant put logs in elasticsearch from logstash

Im using logstash 1.4.2 and ... :slight_smile:
I have the next logstash.conf
input {
udp {
port => 9991
codec => netflow {
definitions => "/home/profucom/logstash-1.4.2/lib/logstash/codecs/netflow/netflow.yaml"
versions => [5]

output {
stdout { codec => rubydebug }
elasticsearch {
index => logstash-%{+YYYY.MM.dd}
host => "localhost"

When i run "./logstash -f logstash.conf works fine, i get all information from my 2 routers, but im not sure if index => logstash-%{+YYYY.MM.dd} write the log.
the log would be stored in curl 'localhost:9200/_cat/indices?v ', or not?
Thanks before all <-<

Notes: I run
1- ./elasticsearch -d
2- ./logstash -f logstash.conf
3.- i put a template for logstash-*
4.- and of curse this code to get information from my routers

You should really upgrade.

Does that work?

Thanks for help!!! but... With
curl 'localhost:9200/_cat/indices?v'
i got this
health index pri rep docs.count docs.deleted store.size pri.store.size
yellow kibana-int 5 1
but i want to put here my index from my routers,
because kibana dont show me nothing.

and I thought that elasticsearch { index => "logstash-%{+YYYY.MM.dd}" host => "localhost" } sent the log from my routers to elasticsearch for could read de log on kibana.

Do you see anything in stdout?

Do you mean about router information? (in my case)
Of curse , i can see traffic of my both routers.

But Honestly, im not sure if this part of code
output {
stdout { codec => rubydebug }
elasticsearch {
index => logstash-%{+YYYY.MM.dd}
host => "localhost"
let elasticsearch get logs from my router and Kibana can read.

That is what I mean. Is there anything visible there?

Yeah man, In the console i can see the out put
how i can save the output in logs, for show it in kibana.
I tried with "index => logstash-%{+YYYY.MM.dd} but does not works.

The rest of the config looks ok.
Can you look at the _cat APIs to see if there is data in your cluster?

Of curse, Mr.

i have the next:

curl http://localhost:9200/_cat/indices?v

health index pri rep doc.count doc.deleted store size pri.store.size
red kibana-int 5 1

my index should look like logstash-xxx-xxx-xxx, but i dont know why isn't working.

Man, i can resolved my problem... i dont know how i can, but i only make a new installation.

And finally kibana shows me information about logs

However, Thank you very much :)!!!!!!!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.