Installing Logstash Plugin with spaces in the install path


(Tim Aitken) #1

I am in the early stages of setting up a an elastic stack and I think I have discovered a bug, but it may be user error, so hopefully someone can point out where I am going wrong.

I have installed Elasticsearch, Logstash and Kibana (5.2 for all) on a Server 2016 server. The path that I have used for install is C:\Program Files\elastic.co<productName>.

The out of the box installations have worked well and everything is functioning as described. I now want to install the 'logstash-output-zabbix' plugin, and this is where I am hitting a problem.

I have run the 'logstash-plugin install' script and received the following error:

c:\Program Files\elastic.co\logstash>bin\logstash-plugin install logstash-output-zabbix
Validating logstash-output-zabbix
Installing logstash-output-zabbix
Error Bundler::InstallError, retrying 1/10
An error occurred while installing logstash-core-event-java (5.2.0), and Bundler cannot continue.
Make sure that `gem install logstash-core-event-java -v '5.2.0'` succeeds before bundling.

This repeats 10 times and eventually fails.

I then tried to install the logstash-core-event-java gem as the error message suggests and get the following error:

c:\Program Files\elastic.co\logstash>"C:\Program Files\elastic.co\logstash\vendor\jruby\bin\gem.bat" install logstash-core-event-java -v 5.2.0
  jar dependencies for logstash-core-event-java-5.2.0-java.gemspec . . .
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-readable POM C:\Program: C:\Program (The system cannot find the file specified) @
 @
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR]   The project  (C:\Program) has 1 error
[ERROR]     Non-readable POM C:\Program: C:\Program (The system cannot find the file specified)
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
ERROR:  While executing gem ... (Errno::ENOENT)
    No such file or directory - C:/Program Files/elastic.co/logstash/vendor/jruby/lib/ruby/gems/shared/gems/logstash-core-event-java-5.2.0-java/deps.lst

The key error here was: "Non-readable POM C:\Program: C:\Program (The system cannot find the file specified)"

This lead me to install logstash in a path with no spaces and try again, and I had success:

c:\ElasticStack\logstash>bin\logstash-plugin install logstash-output-zabbix
Validating logstash-output-zabbix
Installing logstash-output-zabbix
Installation successful

Just to check I ran the gem install process as well:

c:\ElasticStack\logstash>"C:\ElasticStack\logstash\vendor\jruby\bin\gem.bat" install logstash-core-event-java -v 5.2.0
Fetching: ruby-maven-libs-3.3.9.gem (100%)
Successfully installed ruby-maven-libs-3.3.9
Fetching: ruby-maven-3.3.12.gem (100%)
Successfully installed ruby-maven-3.3.12
Fetching: logstash-core-event-java-5.2.0-java.gem (100%)
  jar dependencies for logstash-core-event-java-5.2.0-java.gemspec . . .
      com.fasterxml.jackson.core:jackson-core:2.7.3
      com.fasterxml.jackson.core:jackson-databind:2.7.3
      com.fasterxml.jackson.module:jackson-module-afterburner:2.7.3
      com.fasterxml.jackson.dataformat:jackson-dataformat-cbor:2.7.3
      org.apache.logging.log4j:log4j-api:2.6.2
Successfully installed logstash-core-event-java-5.2.0-java
3 gems installed

Is there some requirement that I have missed to install the elastic products in a path with no spaces? If not, is there someway that I can install the plugin, or even the gem, when there is a space in the path?

Thanks,

Tim


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.