Is APM perfromance like this because of Java version 1.7 at the Application side

Hi All,
After successfully testing APM for the latest freshly newly installed Adempiere (java 1.8) , I was getting the full details of the application perfromance

Later I tried out with our existing live instance of Adempiee (Java 1.7), then APM server shows agent status of the Adempiere( Java 1.7) status, but when it shows nill for average response time, transaction per minute and Error per minutes. I waited for hours to see any changes recorded but no updation happening . This time I had another APM server fresly installed and opened port for 22,5601,8200,9200

What could be the possible reason that it is not displaying the details. Is it because of Java 1.7

I have opened only port 22, 8200, 5601,9200 on my server

Guidance requested

Kibana version:
7.3.1
Elasticsearch version:
7.3.1
APM Server version:
7.3.1
APM Agent language and version:
elastic-apm-agent-1.9.0.jar
Browser version:
Firefox 69
Original install method (e.g. download page, yum, deb, from source, etc.) and version:
deb
Fresh install or upgraded from other version?
Fresh
Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.
No

Can you see anything interesting in the agent log or application/server logs?

Thanks Eyal,
Not able to see the logs, one interesting thing is that when I added the Java 1.8 erp version, it also not showing any result. Let me see if I can add the screen shot

So we can conclude it has not to do the Application Java version , but it is because of other parameter
May be because of some ports blocked, I have only enables

22
8200
5601
9200

Do I need to enable any other parameter
thanks
Joseph John

Apologize please

I could have been bit patience, now I see my Application which is on Java-1.8 pushing data to the APM server, but the ERP server with Java 1.7 not pushing data to the APM server screen shot attached for reference

I could have waited for some time, before posting
Now Applications with 1.8 java is working and APplication with 1.7 not giving data to the APM

We need more info:

  • Agent logs, preferable in DEBUG level
  • Server/application logs
  • Agent installation method and used configurations
  • What is the underlying servlet container?
  • What are the differences between the envs? Only the Java version or more?
1 Like

Hi Eyal,
thanks in future I will include all the above points.
thanks