Issue with getting events over TCP output to TCP input in logstash

Hi i am try to sending events over tcp output to tcp input in logstash but i am not getting event in input side. When i run in debug(input side logstash) mode its showing some messages like

TCP output configuration

output {
    tcp {
      host       => "x.x.x.x"
      port       => 12345
      codec      => json_lines

TCP input coniguration

input {

  tcp {
    port   => "12345"
    codec  => json_lines

The ouput message when i run in debug mode

[2019-05-30T10:44:20,905][DEBUG][logstash.codecs.jsonlines] config LogStash::Codecs::JSONLines/@enable_metric = true
[2019-05-30T10:44:20,905][DEBUG][logstash.codecs.jsonlines] config LogStash::Codecs::JSONLines/@charset = "UTF-8"
[2019-05-30T10:44:20,905][DEBUG][logstash.codecs.jsonlines] config LogStash::Codecs::JSONLines/@delimiter = "\n"
[2019-05-30T10:44:20,919][DEBUG][io.netty.util.Recycler   ] -Dio.netty.recycler.maxCapacity: 262144
[2019-05-30T10:44:20,919][DEBUG][io.netty.util.Recycler   ] -Dio.netty.recycler.maxSharedCapacityFactor: 2
[2019-05-30T10:44:20,919][DEBUG][io.netty.util.Recycler   ] -Dio.netty.recycler.linkCapacity: 16
[2019-05-30T10:44:20,946][DEBUG][io.netty.buffer.AbstractByteBuf] -Dio.netty.buffer.bytebuf.checkAccessible: true

can anyone please help me to resolve this and message size 2.15MB

Verify that you have a TCP connectivity first.
Can you verify using tcpdump that the message arrives on your destination port?

The data arriving to your TCP port would go to the defined heap memory space in your jvm settings.

What is the output in your input tcp configuration?
Can you run with the rubydebug in the output section and show the results?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.