Journabeat (7.6) processors is ignored [Solved]

Journalbeat installation on Linux with default configuration. Output is configured to external Logstash.
Everything works fine except drop_event processors.
Changes applied to journalbeat.yml:

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

  - add_host_metadata: ~
 #- add_cloud_metadata: ~
 #- add_docker_metadata: ~
# This processor should drop events created by jorunalbeat.
  - drop_event:
        # "journalbeat"
          systemd.unit: "journalbeat.service"

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
logging.level: warning

Using different syntax doesn't help:

- "journalbeat"
- drop_event.when.equals.systemd.unit: "journalbeat.service"

Can anyone chime in on why the drop_event process is completely ignored and journalbeat log messages arrive to Logstash regardless the field and name used in the condition?

Thank you in advance,

It turns out that having several processors in the configuration is not supported.
Solved it with moving all rules under a single processors group.