Json Codec dealing with NaN, Inf


(Alex) #1

Hello, I am trying to use the json codec to parse json files that have NaN and Inf as values; however, it doesn't work. I am getting the following error message:

[2018-07-04T17:03:36,005][ERROR][logstash.codecs.json ] JSON parse error, original data now in message field {:error=>#<LogStash::Json::ParserError: Non-standard token 'NaN': enable JsonParser.Feature.ALLOW_NON_NUMERIC_NUMBERS to allow

I'm not sure how to enable the feature through logstash, can anyone help me out on this?


(Alex) #2

Does anyone have a solution for this? Thanks.


(Alex) #3

Bump! How do I enable ALLOW_NON_NUMERIC_NUMBERS in logstash's json codec???


(Alex) #4

Bump


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.