Kafka Input Logging (And Not Consuming)

Hi all,

I'm attempting to get the Kafka input working, with no success so far!

I'd like to see some more logging from it and noticed on its GitHub page...

Kafka logs do not respect the Log4J2 root logger level and defaults to INFO, for other levels, you must explicitly set >the log level in your Logstash deployment's log4j2.properties file, e.g.:


I've not worked with log4j2 configuration before - after adding the above lines to the log4j2.properties file, I receive this warning when running logstash from the console...

log4j:WARN No appenders could be found for logger (org.apache.kafka.clients.consumer.ConsumerConfig).

I know logstash is picking the file up, because I've tried a couple of things and caused (large) Java exceptions.

Can anyone advise on whether I've configured the Kafka input logging for debug properly? It sounds like no, but I've also read some discussion elsewhere suggesting not to worry about this warning. If I have, then I might be back later for more help actually getting this thing to consume!

Kafka input plugin=5.0.5 & 5.1.6 (from "gems" directory)
Kafka version=


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.