Kafka Output Plugin Appears to do Nothing


#1

Hello you wonderful people.

I'm trying to use the Kafka output plugin and thus far I so no evidence it is being invoked.

The debug shows the kafka output-plugin variables on logstash startup, then nothing until logstash is stopped.
When sending messages to logstash(via http input-plugin)

I added a file output-plugin to ensure the messages are processed and the debug shows the file output-plugin processing incoming messages, but nothing for Kafka.
I've run TCP Dumps, prior to starting logstash and see no traffic (using wireshark) on the bootstrap Port Number.
Note: This kafka environment is a new standup currently not in use

hence why I'm here.

My env:
OS: RHEL6
Logstash: 5.4.0 (Also tried 5.3.2)
Kafka-output-plugin: 5.1.6 (Also tried 6.2.0)
Kafka Broker: 0.10.2.0

Plugin: Conf

input {
  http {
        port                    => 8243
        ssl                     => true
        keystore                => "/opt/logstash/keystore.jks"
        keystore_password       => "Password1"
        threads                 => 24
  }
}
output {
  kafka {
        bootstrap_servers => '<ipaddress>:9092'
        topic_id => 'logstash'
  }

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.