Kibanaclient - Error when executing Kibana client request


(antony) #1

I am now using netflow module in my logstash .
And i using " bin/logstash --modules netflow --setup -M netflow.var.input.udp.port=2055 -M var.elasticsearch.hosts="192.168.88.120:9200" -M var.kibana.host="192.168.88.120:5601" "
to start the netflow, but i met an error

[ERROR] 2017-10-13 19:49:59.450 [LogStash::Runner] kibanaclient - Error when executing Kibana client request {:error=>#<Manticore::SocketException: Connection refused (Connection refused)>}
[ERROR] 2017-10-13 19:49:59.461 [LogStash::Runner] kibanaclient - Error when executing Kibana client request {:error=>#<Manticore::SocketException: Connection refused (Connection refused)>}

It seems that i can not connect to the kibana, but when i using telnet , the port is normal.
And i had closed all the firewall,is there anyone who can solve it ?


Logstash Netflow Docs Out of Date?
(Guy Boertje) #2

See https://www.elastic.co/guide/en/logstash/5.6/logstash-modules.html#running-logstash-modules

When using the command line, you must specify which module the setting belongs to. You did this for netflow.var.input.udp.port but not var.elasticsearch.hosts and var.kibana.host

Your command line should look like this.

bin/logstash --modules netflow --setup -M netflow.var.input.udp.port=2055 -M netflow.var.elasticsearch.hosts="192.168.88.120:9200" -M netflow.var.kibana.host="192.168.88.120:5601"

(antony) #3

Wow , it does work,thank you so much .It's been a big help


(Guy Boertje) #4

You are welcome.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.