Lab 2 Assistance (Observability Fundamentals)

I'm stuck at this step, not to much detail is shown to accomplish this.
Now, edit filebeat.yml to configure Filebeat to output to your Elastic Cloud deployment. Insert the following two lines at the end of the config file:

I tried to edit the file with nano, but when I type nano filebeat.yml it opens a blank file, nothing to be replaced. How do I get the file in question?

The instructions say to "nano path/to/filename" but I don't know the path.

Hello,

Did you successfully download filebeat?

If you did all the command listed in step 2.1, your current directory should be: /home/elastic/filebeat-7.12.0-linux-x86_64

You can then run nano filebeat.yml from there.

If this command doesn't work, make sure you're in the correct directory.

Romain

Thanks, I see the problem. I did download it but paused it. When I came back I was unaware I had to download it again, it worked. Thanks

However, Now I'm running into an issue step 9, I'm running the command ./filebeat setup
and I get the following error message
"elastic@ip-xxx-xx-x-xxx~/filebeat-7.12.0-linux-x86_64$ ./filebeat setup
Overwriting ILM policy is disabled. Set setup.ilm.overwrite: true for enabling.

Index setup finished.
Loading dashboards (Kibana must be running and reachable)
Loaded dashboards
Setting up ML using setup --machine-learning is going to be removed in 8.0.0. Please use the ML app instead.
See more: Machine Learning in the Elastic Stack [7.12] | Elastic
Exiting: 1 error: Error setting up ML for nginx_ecs: 10 errors: ; ; ; ; ; ; ; ; ;
elastic@ip-xxx-xx-x-xxx:~/filebeat-7.12.0-linux-x86_64$ "

I do have Kibana running.
BTW I was able to complete the lab, but wondering why those messages show up

Hi @jasieltego ,

this Exiting: 1 error: Error setting up ML for nginx_ecs: 10 errors: ; ; ; ; ; ; ; ; ; is a known issue. You can check more details about it in this link:

Since this issue does not affect any of the lab steps you can just ignore it and proceed with other lab steps.

Thanks,
Andre

By the way, to avoid this issue you can run the following command:

./filebeat setup --dashboards --index-management --pipelines

Best,
Andre