License check warnings and logstash fails to work


(Greg Sullivan) #1

First off Logstash is not on the cluster it is a seperate vm, (Windows)
After installing x-pack for monitoring I get an error spamming my console window,
spamming th logs is this,
[logstash.licensechecker.licensereader] Running health check to see if an Elasticsearch connection is working {:healthcheck_url=>http://localhost:9200/, :path=>"/"}
[2018-01-16T20:24:02,813][WARN ][logstash.licensechecker.licensereader] UNEXPECTED POOL ERROR {:e=>#<LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError: No Available connections>}
But the is no setting for heathcheck url that I can find and localhost won't work of course.

config,
input {
beats {
port => 5044
ssl => true
ssl_certificate_authorities => ["D:\logstash\config\ca\ca.crt"]
ssl_certificate => "D:\logstash\config\logstash\logstash.crt"
ssl_key => "D:\logstash\config\logstash\logstash.key"

} 

}
output {
elasticsearch {
hosts => ["https://xxx:9200"]
ssl => true
cacert => "D:\logstash\config\ca\ca.crt"

}

stdout { codec => rubydebug }


(Mark Walkom) #2

Isn't this the same as Can’t start logstash after x-pack installation?


(Greg Sullivan) #3

yes, sorry about that.


(Mark Walkom) #4