Log4j2.properties not getting honored?


I'm getting warning in my logstash-plain logging file regarding (in this case) the logstash.licensechecker.licensereader. The entry is like this:

[2019-04-03T14:12:05,228][WARN ][logstash.licensechecker.licensereader] Restored connection to ES instance

However, I want to exclude this from my log file via the log4j2.properties. Raising the level to INFO would also be a possibility. However, when I have the following lines in my log4j2.properties file, it 's still showing in my log file.

logger.licensereader.name = logstash.licensechecker.licensereader
logger.licensereader.level = info

What am I doing wrong here?


If you set the log level to INFO, then it will log anything at INFO or above, which includes WARN.

Thanks. Is it also possible to completely disable logging for a plugin? So for lets say the one above?

Rumour has it you can set the level to OFF.

1 Like

Thanks, it works!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.