Logstah stopping pipeline


(1 “Maximys” 1) #1

Hi.
I know that this topic was discussing many time, but I need you help.
I want to start logstash in docker.
When I run docker container with parameter -it, I see that everything is working.
But when I start this command:

root@centos logstash]# docker run -h logstash --name logstash --link elasticsearch:elasticsearch --rm -v "$PWD":/config-dir logstash
Sending Logstash's logs to /var/log/logstash which is now configured via log4j2.properties
15:17:47.807 [main] INFO logstash.modules.scaffold - Initializing module {:module_name=>"fb_apache", :directory=>"/usr/share/logstash/modules/fb_apache/configuration"}
15:17:47.810 [main] INFO logstash.modules.scaffold - Initializing module {:module_name=>"netflow", :directory=>"/usr/share/logstash/modules/netflow/configuration"}
15:17:47.821 [main] INFO logstash.setting.writabledirectory - Creating directory {:setting=>"path.queue", :path=>"/var/lib/logstash/queue"}
15:17:47.824 [main] INFO logstash.setting.writabledirectory - Creating directory {:setting=>"path.dead_letter_queue", :path=>"/var/lib/logstash/dead_letter_queue"}
15:17:47.843 [LogStash::Runner] INFO logstash.agent - No persistent UUID file found. Generating new UUID {:uuid=>"313fe9e6-7319-48ea-8da5-6d86e51dcd52", :path=>"/var/lib/logstash/uuid"}
15:17:48.133 [[main]-pipeline-manager] INFO logstash.pipeline - Starting pipeline {"id"=>"main", "pipeline.workers"=>2, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>5, "pipeline.max_inflight"=>250}
15:17:48.163 [[main]-pipeline-manager] INFO logstash.pipeline - Pipeline main started
15:17:48.239 [Api Webserver] INFO logstash.agent - Successfully started Logstash API endpoint {:port=>9600}
15:17:51.215 [LogStash::Runner] WARN logstash.agent - stopping pipeline {:id=>"main"}
[root@centos logstash]# [LogStash::Runner] WARN logstash.agent - stopping pipeline {:id=>"main"}

It stop container.
Could you please help me to start Logstash?

Thanks in advance.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.