Logstash 6.0.0 Command Line error


(Thomas D.) #1

I'm testing out the Logstash 6.0.0 on Windows server 2012. Here's the pipelines.yml (under directory C:\logstash600\config):

- pipeline.id: winevents
  path.config: "C:/logstash600/pipelines/winevents.cfg"

Here's the file winevents.cfg (under directory C:\logstash600\pipelines):

input {
  beats {
    port => 5052
  }
}
filter{
   if ([type] == "wineventlog") {
      mutate {
         ...
      }
   }
}
output {
   if ([type] == "wineventlog") {
      if ([log_name] == "Application") {
         elasticsearch {
            ...
         }
      }
      else if ([log_name] == "System") {
         elasticsearch {
            ...
         }  
      }
      else if ([log_name] == "Security") {
         elasticsearch {
            ...
         }       
      }
   }
   stdout { codec => rubydebug }
}

There's nothing wrong with the winevents.cfg since I can run it directly. But when I run Logstash in C:\logstash600\bin without any parameter, I got the following error:

Sending Logstash's logs to C:/logstash600/logs which is now configured via log4j2.properties
[ERROR] 2017-08-29 15:48:01.411 [Ruby-0-Thread-1: C:/logstash600/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] sourceloader - No configuration found in the configured sources.

Can someone please help guide me on this error? I thought by default it's looking for the file C:\logstash600\config\pipelines.yml which is there. Not sure what the error means.

Thanks!


(Guy Boertje) #2

Reading through:

It seems that you have set things up correctly.

If you turn on debug logging what additional info do you see?

I don't have a windows machine to test this on. Needless to say, we have tested this extensively (on OSX and Linux) and the feature has been in master for some time.

Can you test on a Linux box perhaps? To confirm whether it is a Windows problem or not.


(Thomas D.) #3

Hi guyboerthe,
I ran cmd: logstash.bat --path.settings=/C:/logstash600/config/
and here's the log:
[2017-09-07T12:01:31,396][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"fb_apache", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x5b358ec8 @module_name="fb_apache", @directory="C:/logstash600/modules/fb_apache/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T12:01:31,412][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"netflow", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x51d4f2c7 @module_name="netflow", @directory="C:/logstash600/modules/netflow/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] -------- Logstash Settings (* means modified) ---------
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] node.name: "abchostname"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] path.data: "C:/logstash600/data"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] modules.cli: []
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] modules: []
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] config.test_and_exit: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] config.reload.automatic: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] config.reload.interval: 3000000000
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] config.support_escapes: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] metric.collect: true
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.id: "main"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.system: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.workers: 4
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.output.workers: 1
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.batch.size: 125
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.batch.delay: 5
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.unsafe_shutdown: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] pipeline.reloadable: true
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] path.plugins: []
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] config.debug: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] *log.level: "debug" (default: "info")
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] version: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] help: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] log.format: "plain"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] http.host: "127.0.0.1"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] http.port: 9600..9700
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] http.environment: "production"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] queue.type: "memory"
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] queue.drain: false
[2017-09-07T12:01:31,427][DEBUG][logstash.runner ] queue.page_capacity: 262144000
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] queue.max_bytes: 1073741824
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] queue.max_events: 0
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] queue.checkpoint.acks: 1024
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] queue.checkpoint.writes: 1024
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] queue.checkpoint.interval: 1000
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] dead_letter_queue.enable: false
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] dead_letter_queue.max_bytes: 1073741824
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] slowlog.threshold.warn: -1
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] slowlog.threshold.info: -1
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] slowlog.threshold.debug: -1
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] slowlog.threshold.trace: -1
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] path.queue: "C:/logstash600/data/queue"
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] path.dead_letter_queue: "C:/logstash600/data/dead_letter_queue"
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] *path.settings: "/C:/logstash600/config/" (default: "C:/logstash600/config")
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] *path.logs: "C:\Logstash600\logs" (default: "C:/logstash600/logs")
[2017-09-07T12:01:31,443][DEBUG][logstash.runner ] --------------- Logstash Settings -------------------
[2017-09-07T12:01:31,443][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/C:/logstash600/config/pipelines.yml"}
[2017-09-07T12:01:31,474][DEBUG][logstash.agent ] Agent: Configuring metric collection
[2017-09-07T12:01:31,474][DEBUG][logstash.instrument.periodicpoller.os] PeriodicPoller: Starting {:polling_interval=>5, :polling_timeout=>120}
[2017-09-07T12:01:31,505][DEBUG][logstash.instrument.periodicpoller.jvm] PeriodicPoller: Starting {:polling_interval=>5, :polling_timeout=>120}
[2017-09-07T12:01:31,537][DEBUG][logstash.instrument.periodicpoller.persistentqueue] PeriodicPoller: Starting {:polling_interval=>5, :polling_timeout=>120}
[2017-09-07T12:01:31,537][DEBUG][logstash.instrument.periodicpoller.deadletterqueue] PeriodicPoller: Starting {:polling_interval=>5, :polling_timeout=>120}
[2017-09-07T12:01:31,552][DEBUG][logstash.agent ] starting agent
[2017-09-07T12:01:31,584][DEBUG][logstash.agent ] Starting puma
[2017-09-07T12:01:31,584][DEBUG][logstash.agent ] Trying to start WebServer {:port=>9600}
[2017-09-07T12:01:31,584][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/C:/logstash600/config/pipelines.yml"}
[2017-09-07T12:01:31,599][DEBUG][logstash.api.service ] [api-service] start
[2017-09-07T12:01:31,646][DEBUG][logstash.agent ] Converging pipelines
[2017-09-07T12:01:31,662][DEBUG][logstash.instrument.periodicpoller.os] PeriodicPoller: Stopping
[2017-09-07T12:01:31,662][DEBUG][logstash.instrument.periodicpoller.jvm] PeriodicPoller: Stopping
[2017-09-07T12:01:31,662][DEBUG][logstash.instrument.periodicpoller.persistentqueue] PeriodicPoller: Stopping
[2017-09-07T12:01:31,662][DEBUG][logstash.instrument.periodicpoller.deadletterqueue] PeriodicPoller: Stopping
[2017-09-07T12:01:31,662][DEBUG][logstash.agent ] Shutting down all pipelines {:pipelines_count=>0}
[2017-09-07T12:01:31,662][DEBUG][logstash.agent ] Converging pipelines

I haven't tried it on Linux yet but will do soon. Meantime if you can help debug this.

Thanks so much!


(Guy Boertje) #4

You should try the -t flag along with the debug log level. This is the config test and exit

In the DEBUG level logging output, if the config file was read correctly, you will see lots of references to the inputs and outputs being setup. in the example below, the lines containing ] config is the config being read, parsed and checked.

As none of this appears, I would say that you have a permissions problem.

Example:

$ bin/logstash -t
Sending Logstash's logs to /tmp/logstash-6.0.0-beta1/logs which is now configured via log4j2.properties
[2017-09-07T17:49:12,863][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"fb_apache", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0xedcaecc @module_name="fb_apache", @directory="/tmp/logstash-6.0.0-beta1/modules/fb_apache/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T17:49:12,866][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"netflow", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x4a34840a @module_name="netflow", @directory="/tmp/logstash-6.0.0-beta1/modules/netflow/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T17:49:12,885][DEBUG][logstash.runner          ] -------- Logstash Settings (* means modified) ---------
.... removed ....
[2017-09-07T17:49:12,890][DEBUG][logstash.runner          ] --------------- Logstash Settings -------------------
[2017-09-07T17:49:12,896][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/tmp/logstash-6.0.0-beta1/config/pipelines.yml"}
[2017-09-07T17:49:12,905][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/tmp/logstash-6.0.0-beta1/config/pipelines.yml"}
[2017-09-07T17:49:13,040][DEBUG][logstash.config.source.local.configpathloader] Skipping the following files while reading config since they don't match the specified glob pattern {:files=>[]}
[2017-09-07T17:49:13,041][DEBUG][logstash.config.source.local.configpathloader] Reading config file {:config_file=>"/tmp/testing/confs/test.conf"}
[2017-09-07T17:49:13,536][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"generator", :type=>"input", :class=>LogStash::Inputs::Generator}
[2017-09-07T17:49:13,578][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"plain", :type=>"codec", :class=>LogStash::Codecs::Plain}
[2017-09-07T17:49:13,582][DEBUG][logstash.codecs.plain    ] config LogStash::Codecs::Plain/@id = "plain_4619c713-2323-4648-9edc-3a890bddd58c"
[2017-09-07T17:49:13,582][DEBUG][logstash.codecs.plain    ] config LogStash::Codecs::Plain/@enable_metric = true
[2017-09-07T17:49:13,582][DEBUG][logstash.codecs.plain    ] config LogStash::Codecs::Plain/@charset = "UTF-8"
[2017-09-07T17:49:13,584][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@lines = ["<1>Oct 16 20:21:22 wonker 1,2016/10/16 20:21:20,3,THREAT,SCAN,6,2016/10/16 20:21:20,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54"]
[2017-09-07T17:49:13,584][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@count = 10
[2017-09-07T17:49:13,584][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@id = "3e3c03b67a3fd567f9ef9361e0ced345840e0cf1-1"
[2017-09-07T17:49:13,584][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@enable_metric = true
[2017-09-07T17:49:13,585][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@codec = <LogStash::Codecs::Plain id=>"plain_4619c713-2323-4648-9edc-3a890bddd58c", enable_metric=>true, charset=>"UTF-8">
[2017-09-07T17:49:13,585][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@add_field = {}
[2017-09-07T17:49:13,585][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@threads = 1
[2017-09-07T17:49:13,586][DEBUG][logstash.inputs.generator] config LogStash::Inputs::Generator/@message = "Hello world!"
[2017-09-07T17:49:13,613][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"stdout", :type=>"output", :class=>LogStash::Outputs::Stdout}
[2017-09-07T17:49:13,621][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"rubydebug", :type=>"codec", :class=>LogStash::Codecs::RubyDebug}
[2017-09-07T17:49:13,625][DEBUG][logstash.codecs.rubydebug] config LogStash::Codecs::RubyDebug/@id = "rubydebug_752f09ec-e718-4c7f-b715-2a1c72aeb530"
[2017-09-07T17:49:13,625][DEBUG][logstash.codecs.rubydebug] config LogStash::Codecs::RubyDebug/@enable_metric = true
[2017-09-07T17:49:13,625][DEBUG][logstash.codecs.rubydebug] config LogStash::Codecs::RubyDebug/@metadata = false
[2017-09-07T17:49:14,785][DEBUG][logstash.outputs.stdout  ] config LogStash::Outputs::Stdout/@codec = <LogStash::Codecs::RubyDebug id=>"rubydebug_752f09ec-e718-4c7f-b715-2a1c72aeb530", enable_metric=>true, metadata=>false>
[2017-09-07T17:49:14,785][DEBUG][logstash.outputs.stdout  ] config LogStash::Outputs::Stdout/@id = "3e3c03b67a3fd567f9ef9361e0ced345840e0cf1-3"
[2017-09-07T17:49:14,786][DEBUG][logstash.outputs.stdout  ] config LogStash::Outputs::Stdout/@enable_metric = true
[2017-09-07T17:49:14,786][DEBUG][logstash.outputs.stdout  ] config LogStash::Outputs::Stdout/@workers = 1
Configuration OK
[2017-09-07T17:49:14,787][INFO ][logstash.runner          ] Using config.test_and_exit mode. Config Validation Result: OK. Exiting Logstash

(Thomas D.) #5

Hi guyboertje,
I ran the cmd: logstash -t --path.settings=/C:/logstash600/config/
and here's the log - it looks like the config is OK. But then it went back to the cmd prompt. Isn't is supposed to be running and waiting for input?

[2017-09-07T14:01:07,592][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"fb_apache", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x28ea5c4a @module_name="fb_apache", @directory="C:/logstash600/modules/fb_apache/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T14:01:07,592][DEBUG][logstash.plugins.registry] Adding plugin to the registry {:name=>"netflow", :type=>:modules, :class=>#<LogStash::Modules::Scaffold:0x3c4988e1 @module_name="netflow", @directory="C:/logstash600/modules/netflow/configuration", @kibana_version_parts=["6", "0", "0"]>}
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] -------- Logstash Settings (* means modified) ---------
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] node.name: "..."
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] path.data: "C:/logstash600/data"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] modules.cli: []
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] modules: []
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] *config.test_and_exit: true (default: false)
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] config.reload.automatic: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] config.reload.interval: 3000000000
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] config.support_escapes: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] metric.collect: true
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.id: "main"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.system: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.workers: 4
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.output.workers: 1
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.batch.size: 125
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.batch.delay: 5
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.unsafe_shutdown: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] pipeline.reloadable: true
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] path.plugins: []
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] config.debug: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] *log.level: "debug" (default: "info")
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] version: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] help: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] log.format: "plain"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] http.host: "127.0.0.1"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] http.port: 9600..9700
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] http.environment: "production"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.type: "memory"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.drain: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.page_capacity: 262144000
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.max_bytes: 1073741824
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.max_events: 0
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.checkpoint.acks: 1024
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.checkpoint.writes: 1024
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] queue.checkpoint.interval: 1000
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] dead_letter_queue.enable: false
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] dead_letter_queue.max_bytes: 1073741824
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] slowlog.threshold.warn: -1
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] slowlog.threshold.info: -1
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] slowlog.threshold.debug: -1
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] slowlog.threshold.trace: -1
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] path.queue: "C:/logstash600/data/queue"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] path.dead_letter_queue: "C:/logstash600/data/dead_letter_queue"
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] *path.settings: "/C:/logstash600/config/" (default: "C:/logstash600/config")
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] *path.logs: "C:\Logstash600\logs" (default: "C:/logstash600/logs")
[2017-09-07T14:01:07,623][DEBUG][logstash.runner ] --------------- Logstash Settings -------------------
[2017-09-07T14:01:07,623][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/C:/logstash600/config/pipelines.yml"}
[2017-09-07T14:01:07,638][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/C:/logstash600/config/pipelines.yml"}
[2017-09-07T14:01:07,654][INFO ][logstash.runner ] Using config.test_and_exit mode. Config Validation Result: OK. Exiting Logstash


(Thomas D.) #6

I ran it again and got this error at the end of the log:

[2017-09-07T15:16:00,420][DEBUG][logstash.agent ] starting agent
[2017-09-07T15:16:00,436][DEBUG][logstash.agent ] Starting puma
[2017-09-07T15:16:00,436][DEBUG][logstash.agent ] Trying to start WebServer {:port=>9600}
[2017-09-07T15:16:00,436][DEBUG][logstash.config.source.multilocal] Reading pipeline configurations from YAML {:location=>"/C:/logstash600/config/pipelines.yml"}
[ERROR] 2017-09-07 15:16:00.452 [Ruby-0-Thread-1: C:/logstash600/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] sourceloader - No configuration foun
d in the configured sources.
[2017-09-07T15:16:00,467][DEBUG][logstash.api.service ] [api-service] start
[2017-09-07T15:16:00,467][DEBUG][logstash.agent ] Converging pipelines
[2017-09-07T15:16:00,499][DEBUG][logstash.instrument.periodicpoller.os] PeriodicPoller: Stopping
[2017-09-07T15:16:00,499][DEBUG][logstash.instrument.periodicpoller.jvm] PeriodicPoller: Stopping
[2017-09-07T15:16:00,499][DEBUG][logstash.instrument.periodicpoller.persistentqueue] PeriodicPoller: Stopping
[2017-09-07T15:16:00,499][DEBUG][logstash.instrument.periodicpoller.deadletterqueue] PeriodicPoller: Stopping
[2017-09-07T15:16:00,530][DEBUG][logstash.agent ] Shutting down all pipelines {:pipelines_count=>0}
[2017-09-07T15:16:00,545][DEBUG][logstash.agent ] Converging pipelines

==========================================
Notice the error above - not sure what this means:

[ERROR] 2017-09-07 15:16:00.452 [Ruby-0-Thread-1: C:/logstash600/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:22] sourceloader - No configuration found in the configured sources.


(Thomas D.) #7

Hi Guy, it's all good. I got it working. Simple error. Must be --path.settings=/C:/logstash600/config/
Thanks!


Sourceloader - No configuration found in the configured sources error in logstash
(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.