Logstash 6.8.3 not exporting its metrics, running on CentOS 7

I am running the rpm version of Logstash 6.8.3 on full GUI based CentOS 7 running locally on VM Player on my desktop.
Downloaded the rpm version from official site.
This version does not export its metrics via xpack.monitoring .
Interestingly, when I installed the same rpm version of Logstash 6.8.3 on minimal CentOS 7 VM running on Azure cloud, it exports its metrics to Elasticsearch.
Is this issue related to OSS builds? I don't understand what it means.

My logstash.yml file:

node.name: logstash-vm0

path.data: /var/lib/logstash

pipeline.id: server-pipeline

pipeline.workers: 2

pipeline.batch.size: 125

# pipeline.batch.delay: 50

# pipeline.unsafe_shutdown: false

#path.config: /etc/logstash/pipelines/*.conf

# config.string:

# config.test_and_exit: false

config.reload.automatic: true

config.reload.interval: 5s

# config.debug: false

# config.support_escapes: false

# modules:
#   - name: MODULE_NAME
#     var.PLUGINTYPE1.PLUGINNAME1.KEY1: VALUE


# modules:

# cloud.id: <identifier>
#
# cloud.auth: elastic:<password>

queue.type: "persisted"
path.queue: /var/lib/logstash/queue
queue.page_capacity: 64mb
queue.max_events: 0
queue.max_bytes: 1024mb
queue.checkpoint.writes: 1024
queue.checkpoint.interval: 1000
dead_letter_queue.max_bytes: 1024mb

path.dead_letter_queue: /var/lib/logstash/dead_letter_queue

# ------------ Metrics Settings --------------
# Bind address for the metrics REST endpoint
http.host: "10.0.0.7"
# Bind port for the metrics REST endpoint, this option also accept a range
# (9600-9700) and logstash will pick up the first available ports.
http.port: 9600


path.logs: /var/log/logstash

# ------------ X-Pack Settings (not applicable for OSS build)--------------
#
# X-Pack Monitoring
# https://www.elastic.co/guide/en/logstash/current/monitoring-logstash.html
xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.username: "logstash_system"
xpack.monitoring.elasticsearch.password: "******"
xpack.monitoring.elasticsearch.hosts: "https://elasticsearch-client-vm0:9200"
xpack.monitoring.elasticsearch.ssl.certificate_authority: "/etc/logstash/certs/elasticsearch-master-vm0/ca.crt"
xpack.monitoring.elasticsearch.ssl.verification_mode: certificate
xpack.monitoring.elasticsearch.sniffing: false
xpack.monitoring.collection.interval: 10s
xpack.monitoring.collection.pipeline.details.enabled: true

# X-Pack Management
# https://www.elastic.co/guide/en/logstash/current/logstash-centralized-pipeline-management.html
xpack.management.enabled: true
xpack.management.pipeline.id: ["server-pipeline"]
xpack.management.elasticsearch.username: "logstashadmin"
xpack.management.elasticsearch.password: "******"
xpack.management.elasticsearch.hosts: "https://elasticsearch-client-vm0:9200"
xpack.management.elasticsearch.ssl.certificate_authority: "/etc/logstash/certs/elasticsearch-master-vm0/ca.crt"
xpack.management.elasticsearch.ssl.verification_mode: certificate
xpack.management.elasticsearch.sniffing: false
xpack.management.logstash.poll_interval: 5s