Logstash.agent successfully started logstash enpoint port 9600

hello guys
i'm facing a problem .. logstrash can not load data to elasticsearch
i'm using my own config file ..and it seems ok for me ..when i run it ..it shows no error but the end point is port 9600 instead of 9200
here is my config file :
input {
file {
path => "C:/filec/new2.log"
start_position => beginning
ignore_older => 0
sincedb_path => "NIL" #easier to remove from the current directory, the file will be NIL.sincedb
type => "logs"


filter {
output {
stdout { codec => rubydebug }

and here the result after i run it :

This says to ignore any files that were created zero or more seconds ago, which is all files. Remove it.

thank you for replying..
i did removed it but it still show the same thing


Whats is the version of Elastic stack you are using ?
Because the type is deprecated in new versions of stack

just go with the following code in the input section of logstash and give it a try

file {
path => "C:/filec/new2.log"
start_position => beginning

i don't understand the problem. logstash usually start on port 9600.

that's fine which means the logstash is working (up and running).

1)Some times it gets struck their
then open the file and add/delete some lines and save the file

These can help because the logstash is up and it is waiting for active file.

if the above didn't work try the below one.

2)Check file has read and write permissions if not make sure it has

if you are linux user
chmod 777

Hope this solves your issue.

thank you so much Vamsi_Vutukuri
an add/delete was the solution :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.