Logstash automatically adding port

I have logstash running on an AWS EC2 instance and am trying to connect it to an AWS Elasticsearch domain. When starting up Logstash, it won't connect to the ES domain, and appends port 443 to the URL of the domain. I never specified a port in my access policy, which I think is part of why it won't connect. Is there any place I can change the settings so it doesn't try to connect on a specific port? Or is that just how Logstash works?