Logstash Bind Issue? (solved

I was wondering if someone has had this issue before?

So everything is working on my Ubuntu server 14.04 and the logs are coming in no issue there.

But when i need to check something with

tail -f /var/log/logstash/logstash.stdout

I get
The error reported is:
Address already in use - bind - Address already in use

then I thought logstash was trying to bind to the same port as kibana

so i tried

echo manual | sudo tee /etc/init/logstash-web.override

still no fix :frowning:

Thank you

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them. :slight_smile:

Can you show us your config? What version are you on? Is LS already running?

Thank you again for the reply, Sorry for the picture,

I am running logstash 1.4.2-1 and yes logstash is working whats odd it that everything is working but when i run the command tails shows as if theres another port I even tried changing it to 5145 while its on 5140 but nothing.

Thank you

That's a really old version, you should upgrade.

Thank you for the reply,

But I just updated logstash to 1.4.5-1

still the same issue any suggestions? or where should i start looking?

Thank you

That'd help!
Also a ps showing any java processes.

thank you again for the quick reply, so i ran

sudo netstat -plnt | grep ':5140'

and got

tcp6 0 0 :::5140 :::* LISTEN 281/java

so java for some odd reason is listening on that port odd..

Well this is my logstash config


Thank you

So what other java processes are running?

well I wanted to install ELK on ubuntu server 14.04 because before I had it on lubuntu I ran the same config and step which is odd... when i install java i used this command

sudo add-apt-repository -y ppa:webupd8team/java && sudo apt-get update && sudo apt-get -y install oracle-java7-installer;

And no issue there but not sure why its giving me this issue. Whats even funnier that logstash is working fine the logs but when i want to run Tail to logstash get that issue :frowning: could it be something with the permissions?

See ^

Thank you again reply,

I ran pstree and got this

`root@ELK:~# pstree

then I ran
root@ELK:~# pgrep -fl java
937 java
2367 java

so I have two Javas?

Looks like another LS instance may be running then?

Not really sure when you say LS? another service? i tried uninstalling java but no luck there either

I just ended up going back to lubuntu 15.04 Works flawless i tried ubuntu server 14.04 could not get it work thanks again :smile: