Logstash can't start afer upgrading VM


(yami) #1

Before it worked fine, then VM was added a more processors and this occurs

[root@localhost logstash]# bin/logstash -f centralLogstash.conf --quiet --path.data usr/share/logstash/tmp
Invalid file name for use with -Xloggc: Filename can only contain the characters [A-Z][a-z][0-9]-_.%[p|t] but it has been ${LS_GC_LOG_FILE}
Note %p or %t can only be used once
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
[root@localhost logstash]#

What can be the reason ?

[root@localhost config]# ls
jvm.options log4j2.properties logstash.yml startup.options
[root@localhost config]# pwd
/usr/share/logstash/config
[root@localhost config]# vi jvm.options

(...)
# log GC status to a file with time stamps
# ensure the directory exists
#-Xloggc:${LS_GC_LOG_FILE}

Logstash 5.2.2


(Guy Boertje) #2

The # indicated that it is commented out.

Are you running LS as a package? I am wondering if LS is picking up a different config dir than the one you have shown here.


(yami) #3

Yeah, probbably it was taking config from etc/logstash

I installed it as RPM - still dont know why it takes another config file.

thanks - now it works.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.