Logstash config failed


(Abdur Raqeeb) #1

HI,

Please help me here as my logstash config is getting failed.Please find the error and logstash config file

grok {
match => { "message" => { '%{IP:remote_address} - "remote user" - ["local time" %{HTTPDATE:time}] "Request" "%{GREEDYDATA:request}" "status code" %{INT:http_status_code} "bytes Transfer" %{NOTSPACE:bytes-transfer} "http_refere ""-" "http user agent" "%{DATA:httpuseragent}" "http x forwaded for" "%{DATA:http_x_forwarded_for}""requesttime" "%{DATA:requesttime}" "upstream time" "%{DATA:upstream_time}"}' }

add_field => [ "received_at", "%{@timestamp}" ]
add_field => [ "received_from", "%{host}" ]

}

usr/share/logstash/bin/logstash -t -f /etc/logstash/conf.d/beats.conf
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
[WARN ] 2018-06-27 15:03:41.371 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified
[FATAL] 2018-06-27 15:03:42.488 [LogStash::Runner] runner - The given configuration is invalid. Reason: Expected one of #, => at line 9, column 412 (byte 474) after filter {
grok {
match => { "message" => { '%{IP:remote_address} - "remote user" - ["local time" %{HTTPDATE:time}] "Request" "%{GREEDYDATA:request}" "status code" %{INT:http_status_code} "bytes Transfer" %{NOTSPACE:bytes-transfer} "http_refere ""-" "http user agent" "%{DATA:httpuseragent}" "http x forwaded for" "%{DATA:http_x_forwarded_for}""requesttime" "%{DATA:requesttime}" "upstream time" "%{DATA:upstream_time}"}'
[ERROR] 2018-06-27 15:03:42.504 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Please update


(Magnus B├Ąck) #2

You have:

match => { "message" => { '...' }

Change this to:

match => { "message" => '...' }

Also, it looks like you have an extra } at the end of your grok expression.


(Abdur Raqeeb) #3

thanks its fixed now


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.