Logstash Config Files (Am I doing something wrong)

Hi everyone, I have been working with the elastic stack for a short while. I have been following a udemy class about setting all of it up. Right now I am facing a really confusing problem with the Logstash setup. I am working on getting a configuration file for it, but everytime I use my config file Logstash tells me there is none and shuts down. I am wondering if anyone can help me with this problem?

input {
file {
path => C:\Users\alexk\Desktop\ELK\logstash-7.0.1\logs\apache-logs.txt
start_position => beginning
filter {
grok {
match => { "message" => "%{COMBINEDAPACHELOG}"}
geoip {
source => "clientip"
output {
elasticsearch {}
stdout {}

This is what my config file looks like. Am I doing anything wrong? If so I would love to know.

Can you share the logstash error message so that it would be easy to understand where it is going wrong.

Use forward slash in the path option of a file input on Windows, not backslash.

I don't have an error code, but I am getting this messege.

[2019-05-21T10:24:28,855][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"C:/Users/alexk/Desktop/ELK/logstash-7.0.1/pipeline.conf"}

I'll try that real quick

Alright this is the whole process from startup to failure. I tried what you said Badger, and I got the same result.

Sending Logstash logs to C:/Users/alexk/Desktop/ELK/logstash-7.0.1/logs which is now configured via log4j2.properties
[2019-05-21T10:36:55,426][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2019-05-21T10:36:55,477][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.0.1"}
[2019-05-21T10:36:56,436][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"C:/Users/alexk/Desktop/ELK/logstash-7.0.1/pipeline.conf"}
[2019-05-21T10:36:56,459][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2019-05-21T10:36:57,143][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2019-05-21T10:37:01,882][INFO ][logstash.runner ] Logstash shut down.

I think it should be backward slash. Please check your pipeline.conf file.. It shoudn't be empty.

I made sure that my pipeline.config file is not empty and I am still getting the same error. Should I try re-installing logstash again?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.