Logstash configuration always run sql mode

Hi folks, I just found out that my logtash always run query set sql_mode='no_engine_substitution,strict_trans_tables' every 10s.

i see that user api_elastics always run that query every 10s in mysql log history.

this is my configuration :

# Sample Logstash configuration for creating a simple
# Beats -> Logstash -> Elasticsearch pipeline.

input {
   jdbc {
    jdbc_driver_library => "/etc/mysql-connector/mysql-connector-java-5.1.46/mysql-connector-java-5.1.46-bin.jar"
    jdbc_driver_class => "com.mysql.jdbc.Driver"
    jdbc_connection_string => "jdbc:mysql://domain.com:3306/ohmydb"
    jdbc_user => "api_elastics"
    jdbc_password => "{asdf"
    schedule => "*/10 * * * * *"
    statement => "SELECT * FROM tokdis.view_product_autosuggest"
    clean_run => true
  }
}

filter {
  mutate {
    convert => {
      "price" => "integer"
    }
  }
}

output {
  elasticsearch {
    hosts => ["https://domain.com:443"]
    index => "search_suggestion"
    document_id => "%{id}"
  }
 stdout { codec => rubydebug }
}

I have no idea how to disable this setting.

is there any solution for this one?

c'mon guys, I stucked on this problem and still have no idea for this. :pensive: :pensive: :pensive: :pensive: :pensive: :pensive: :pensive: :pensive:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.