Logstash didn't send data to output


#1

I confirmed that data has sent from filebeat client to logstash successfully from following logs

output received {:event=>{"message"=>"2018-01-31T15:45:22-08:00 INFO Home path: [/Users/tracywan/work/BoxRelay/filebeat-6.1.3-darwin-x86_64] Config path: [/Users/tracywan/work/BoxRelay/filebeat-6.1.3-darwin-x86_64] Data path: [/Users/tracywan/work/BoxRelay/filebeat-6.1.3-darwin-x86_64/data] Logs path: [/Users/tracywan/work/BoxRelay/filebeat-6.1.3-darwin-x86_64/logs]", "@version"=>"1", "@timestamp"=>"2018-02-01T19:28:48.389Z", "offset"=>391, "prospector"=>{"type"=>"log"}, "beat"=>{"name"=>"box_relay_shipper", "hostname"=>"tracys-mbp-3.usca.ibm.com", "version"=>"6.1.3"}, "source"=>"/var/log/filebeat/beat.log", "host"=>"tracys-mbp-3.usca.ibm.com", "tags"=>["beats_input_codec_plain_applied"]}, :level=>:debug, :file=>"(eval)", :line=>"19", :method=>"output_func"}
output received {:event=>{"message"=>"2018-01-31T15:45:22-08:00 DBG [beat] Beat metadata path: /Users/tracywan/work/BoxRelay/filebeat-6.1.3-darwin-x86_64/data/meta.json", "@version"=>"1", "@timestamp"=>"2018-02-01T19:28:48.390Z", "source"=>"/var/log/filebeat/beat.log", "offset"=>523, "prospector"=>{"type"=>"log"}, "beat"=>{"hostname"=>"tracys-mbp-3.usca.ibm.com", "version"=>"6.1.3", "name"=>"box_relay_shipper"}, "host"=>"tracys-mbp-3.usca.ibm.com", "tags"=>["beats_input_codec_plain_applied"]}, :level=>:debug, :file=>"(eval)", :line=>"19", :method=>"output_func"}
output received {:event=>{"message"=>"2018-01-31T15:45:22-08:00 INFO Metrics logging every 30s", "@version"=>"1", "@timestamp"=>"2018-02-01T19:28:48.390Z", "source"=>"/var/log/filebeat/beat.log", "offset"=>580, "prospector"=>{"type"=>"log"}, "beat"=>{"name"=>"box_relay_shipper", "hostname"=>"tracys-mbp-3.usca.ibm.com", "version"=>"6.1.3"}, "host"=>"tracys-mbp-3.usca.ibm.com", "tags"=>["beats_input_codec_plain_applied"]}, :level=>:debug, :file=>"(eval)", :line=>"19", :method=>"output_func"}
output received {:event=>{"message"=>"2018-01-31T15:45:22-08:00 INFO Beat UUID: 53057e74-34bc-4e56-91ab-1823fc94c8eb", "@version"=>"1", "@timestamp"=>"2018-02-01T19:28:48.390Z", "offset"=>659, "prospector"=>{"type"=>"log"}, "beat"=>{"name"=>"box_relay_shipper", "hostname"=>"tracys-mbp-3.usca.ibm.com", "version"=>"6.1.3"}, "source"=>"/var/log/filebeat/beat.log", "host"=>"tracys-mbp-3.usca.ibm.com", "tags"=>["beats_input_codec_plain_applied"]}, :level=>:debug, :file=>"(eval)", :line=>"19", :method=>"output_func"}
Pushing flush onto pipeline {:level=>:debug, :file=>"logstash/pipeline.rb", :line=>"458", :method=>"flush"}
Pushing flush onto pipeline {:level=>:debug, :file=>"logstash/pipeline.rb", :line=>"458", :method=>"flush"}

But after that I don't see my output.

output {
stdout {}
}

I used debug on logstash, no errors, it just keeps piping out Pushing flush onto pipeline {:level=>:debug, :file=>"logstash/pipeline.rb", :line=>"458", :method=>"flush"}


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.