Logstash does not parse date when ingesting data

I have a large CSV file with many columns, and when I first ingested it into elasticsearch, everything worked fine, and all the dates that I specified in the date filters were parsed properly.

However after adding 3 columns of data into the CSV file, for some reason when I tried to ingest the data again, Logstash was unable to parse the dates.

P.S All the dates I have in the CSV are formatted to short date.

Here is my config file:

    filter {
    	csv {
    		separator => ","
    		autodetect_column_names => "false"
    		autogenerate_column_names => "true"
    		skip_empty_columns => "true"
    		columns => ["Data Type", ... a bunch of other columns defined]

        /*Date filters for all date fields in the exact same format*/

    	date {
    		match => ["EOSL_its_end_of_support_hw", "MM/dd/YYYY"]
    		target => "EOSL_its_end_of_support_hw"
... Config file continues

Is there something wrong with my config file that I am missing?

can you show your new data sample which you are adding into CVS file.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.