Logstash Elasticsearch output error


(Dong Zhou) #1

Hi, I'm trying to setup a simple Elastic Stack where Logstash pulls data from Twitter and outputs to ES.

output {
elasticsearch {
hosts => XXXXXX
user => XXXXXX
password => XXXXXX
index => "twitter"
document_type => "tweets"
template => "twitter_template.json"
template_name => "twitter"
}
}

When I tested this simple conf file, I got the following error messages:

[2016-12-12T22:39:34,925][ERROR][logstash.outputs.elasticsearch] Encountered an unexpected error submitting a bulk request! Will retry. {:error_message=>"undefined method response' for #<LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError:0x2926fa12>", :class=>"NoMethodError", :backtrace=>["/usr/local/Cellar/logstash/5.1.1/libexec/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-5.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:223:insafe_bulk'", "/usr/local/Cellar/logstash/5.1.1/libexec/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-5.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:109:in submit'", "/usr/local/Cellar/logstash/5.1.1/libexec/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-5.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:76:inretrying_submit'", "/usr/local/Cellar/logstash/5.1.1/libexec/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-5.4.0-java/lib/logstash/outputs/elasticsearch/common.rb:27:in multi_receive'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/output_delegator_strategies/shared.rb:12:inmulti_receive'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/output_delegator.rb:42:in multi_receive'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/pipeline.rb:331:inoutput_batch'", "org/jruby/RubyHash.java:1342:in each'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/pipeline.rb:330:inoutput_batch'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/pipeline.rb:288:in worker_loop'", "/usr/local/Cellar/logstash/5.1.1/libexec/logstash-core/lib/logstash/pipeline.rb:258:instart_workers'"]}

Does anyone know what's going on? Thanks!

-- Dong


(Mark Walkom) #2

Check your ES logs, there should be more.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.