Logstash fails to start the simplest pipeline


(Letharion) #1
# java -version
openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14)
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)

# bin/logstash --version
logstash 5.0.1

# time bin/logstash -e 'input { stdin { } } output { stdout {} }'
^C
real    4m34.311s
user    0m13.224s
sys     0m0.268s

# cat /etc/issue
Ubuntu 16.04.1 LTS \n \l

Freshly installed ubuntu VM, with logstash pulled in from the official deb packages as shown here: https://www.elastic.co/guide/en/logstash/current/installing-logstash.html

Tried running as root to avoid any sort of permissions issue, which doesn't help.


(Magnus B├Ąck) #2

On a first look things looked normal since you weren't supplying anything on stdin so Logstash would naturally wait for input, but a) unless this has changed in Logstash 5 it'll log something to stdout to indicate that it's alive and b) 13 seconds of CPU time just for starting up sounds excessive.

Have you tried bumping up the log level?


(Letharion) #3

It turned out that if I had waited just a little longer, after about 5 minutes logstash does start and work as expected.
Not quite sure what the 5 minute mark was about, some kind of timeout perhaps, but what it's waiting for was unclear to me.

In either case I moved on with the setup, and got logstash working, so while the time it took for logstash to start in my example was annoying, ultimately it turned out to be a red herring. It does not take 5 min for logstash to start up when the full setup is inplace, as opposed to the the inline config sample above.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.