Logstash file input [roblem after upgrade to JRE 1.8 211

Hi,
I updated my java runtime today from build 1.8 181 to 1.8 211 and suddenly started seeing errors. it might or might not be related, as at the same time I started using a new pipeline, but I have never had such errors before and I actually use the new pipe on the same files I used my other pipelines with....
Since I installed the new JRE I am getting errors of this sort:

[2019-04-21T16:28:42,761][ERROR][filewatch.tailmode.handlers.grow] read_to_eof: general error reading <ron - filename was here > {"error"=>"#<SystemCallError: Unknown error (SystemCallError) - No message available>", "backtrace"=>["org/jruby/RubyIO.java:3014:in sysread'", "F:/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.10/lib/filewatch/watched_file.rb:218:infile_read'", "F:/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.10/lib/filewatch/watched_file.rb:230:in read_extract_lines'", "F:/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.10/lib/filewatch/tail_mode/handlers/base.rb:52:inblock in controlled_read'"]}

Any idea?
@guyboertje maybe you can help here too.....

Thanks!
Ron

@guyboertje just to add some info here. I previously ran the same pipeline on some test data with no problems. I just tried copying the test data to my pipeline again, this time I had errors. so it does feel like a java version issue. which

And yet another update. I looked at the elastic documentation and realized I was supposed to actually use the JDK that comes with elastic. this is probably not the most secure thing we can do as there are vulnerabilities found, but it does work now so the problem is 100% with the java version. for me it's not an issue anymore, I will continue using the elastic shipped JDK, but do know that it is coming. I used JRE 1.8 build 181 and everything worked fine, now with JRE 1.8 211 (released April 16th) it broke.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.