Logstash: Got response code '405' contacting Elasticsearch

When trying to connect Logstash to ElasticSearch I'm getting this error and I don't understand why. The error mentions a "dead ES instance" but ElasticSearch is running and I'm able to access the API with curl from the server.
Config : Debian 9



Hi @tom55 , Welcome to the community!
Could you show us your logstash config file?

Hello @KrishnaShah7

thanks for help

the config file conf.d ? logstash.yml ? logstash-sample.conf?

@tom55 : Logstash.yml please.

Hello @KrishnaShah7

here is the conf file:

Thanks @tom55 . Could you also send me your conf file ? I believe you have made your configuration in logstash-sample.conf ?

@KrishnaShah7 here is the file

Hi @tom55 ,
If you have TLS enabled, in your logstash conf output plugin, hosts => ["http://localhost:9200"] won't work. You might want to check using https instead.

Also have you enabled Xpack ? If yes, then that might require you to add some settings to your logstash.yml which you havent added.


the problem came from an incompatibility between logstash and ES which had different versions.

Thanks for help @KrishnaShah7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.