Logstash input not ingesting distinct file

Hello everyone

I would like to ingest text and csv files using Logstash to send them into Elasticsearch. The problem is that it's not working and Logstash does not indicate any errors.
The index is not created, there's nothing in the log.
I have unchecked the read-only on folder containing files I want to ingest.
I have added to logstash config the parameters "start_position" and "sincedb_path", it's still not working.

I have created this configuration for logstash :

 input {
     file {
          path => "C:\logs\*.txt"
          type => "logs"
          start_position => "beginning"
          sincedb_path => "C:\logs\null"
output {
     elasticsearch {
          hosts => ["localhost:9200"]
          index => "logtest"

About versions, I use Elasticsearch 7.5.1, logstash 7.5.1 and kibana 7.5.1.

Thankyou for your help

Do not use backslash in the path option of a file input. Use forward slash.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.