Logstash install and startup error

Good Afternoon;
I am new to the ELK tools and am in the midst of a proof of concept using them. I am testing on a Windows 10 Professional box and have been able to install and get running both ElasticSearch and Kibana. However when I attempt to run the Logstash I receive the following:

logstash stopped processing becase of an error: (SystemExit) exit org.jruby.exception.SystemExit: (SystemExit) exit.

i have been following the How to Install ElkStack found on the following website:

This has worked for the most part. When I go through the process for the Logstash it does start the API on port 9600 and then immediately turns it off.

Any help is much appreciated. I am still in the testing phase.


What does you logstash configuration file look like? What other messages does logstash log?


My logstash config file is very basic at the moment. It is a copy and past of the logstash-sample.conf file. The logstash-plain log file is the only one collecting data, the depreication.log and slowlog-plain.log are not being populated. What I am seeing the logstash-plain.log file is:

Thank you for your feedback and assistance.

and what is that?

Sorry, thought I had it copied out. Here is what is repeated in the logstash-plain log.

[2021-05-17T13:13:09,198][INFO ][logstash.runner ] Log4j configuration path used is: D:\ELK\Logstash\logstash-7.12.1\config\log4j2.properties
[2021-05-17T13:13:09,211][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"7.12.1", "jruby.version"=>"jruby (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.10+9 on 11.0.10+9 +indy +jit [mswin32-x86_64]"}
[2021-05-17T13:13:09,342][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2021-05-17T13:13:10,049][INFO ][logstash.config.source.local.configpathloader] No config files found in path {:path=>"d:/elk/logstasch/bin/logstasch.conf"}
[2021-05-17T13:13:10,132][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2021-05-17T13:13:10,347][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
[2021-05-17T13:13:10,468][INFO ][logstash.runner ] Logstash shut down.
[2021-05-17T13:13:10,479][FATAL][org.logstash.Logstash ] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-]
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-]
at D_3a_.ELK.Logstash.logstash_minus_7_dot_12_dot_1.lib.bootstrap.environment.(D:\ELK\Logstash\logstash-7.12.1\lib\bootstrap\environment.rb:89) ~[?:?]

The file does not exist. Is logstasch a typo?

Thank you for catching those spelling mistakes. I have been looking at this for too long the extra set of eyes is a big help. I will make the changes and let you know what the results are.


I got it to work. Thank you for your help in this.
End result was I left out a branch in the folders to get to where the logstach.conf file was. After i added the full path to the conf file it worked.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.