Logstash installation error


(Joe) #1

This is frst time trying to install Logstash on linux/ubuntu. I keep running into an error that logstash can't start. I have no clue what I did wrong. So I would be grateful if anyone can point me what I can do correct this. Thank you

The following are the errors that logstash gives

ubuntu@ip-172-31-6-195:~$ cd logstash-6.1.2/
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ bin/logstash -e 'input { stdin { } } filter {} output { stdout { codec => rubydebug }'
Sending Logstash's logs to /home/ubuntu/logstash-6.1.2/logs which is now configured via log4j2.properties
[2018-01-21T02:55:11,155][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"/home/ubuntu/logstash-6.1.2/modules/fb_apache/configuration"}
[2018-01-21T02:55:11,195][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"/home/ubuntu/logstash-6.1.2/modules/netflow/configuration"}
[2018-01-21T02:55:11,256][FATAL][logstash.runner ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "" hasn't been registered>, :backtrace=>["/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:32:in get_setting'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:65:inset_value'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in block in merge'", "org/jruby/RubyHash.java:1343:ineach'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in merge'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:133:invalidate_all'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:259:in execute'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:inrun'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:214:in run'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:inrun'", "/home/ubuntu/logstash-6.1.2/lib/bootstrap/environment.rb:67:in `'"]}
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$

ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ clear
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$ bin/logstash -e
Sending Logstash's logs to /home/ubuntu/logstash-6.1.2/logs which is now configured via log4j2.properties
[2018-01-21T02:56:14,552][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"/home/ubuntu/logstash-6.1.2/modules/fb_apache/configuration"}
[2018-01-21T02:56:14,565][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"/home/ubuntu/logstash-6.1.2/modules/netflow/configuration"}
[2018-01-21T02:56:14,618][FATAL][logstash.runner ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "" hasn't been registered>, :backtrace=>["/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:32:in get_setting'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:65:inset_value'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in block in merge'", "org/jruby/RubyHash.java:1343:ineach'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:84:in merge'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/settings.rb:133:invalidate_all'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:259:in execute'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:inrun'", "/home/ubuntu/logstash-6.1.2/logstash-core/lib/logstash/runner.rb:214:in run'", "/home/ubuntu/logstash-6.1.2/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:inrun'", "/home/ubuntu/logstash-6.1.2/lib/bootstrap/environment.rb:67:in `'"]}
ubuntu@ip-172-31-6-195:~/logstash-6.1.2$


(Joe) #2

I fixed the problem. Embarrasingly, this problem went away after I downloaded logstash.zip and installed. However, logstash.tar.gz still gave me the problem shown above. So my recommendation is to use .zip file download on Ubuntu.


#3

An alternative is to use Debian package.

https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html


(Joe) #4

Thank you, Mojster!


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.