Logstash installation folder in Windows


(Firass Gzayil) #1

Hi,
I am trying to run logstash under c:\program files
but I get an error
An unexpected error occurred! :error => bad URI(is not URI?): file://C:/Program Files/Infra/Data/Shipper/logstash5/config/log4j2.properties, :backtrace => ["C:/Program Files/Infra/Data/Shipper/logstash5/vendor/jruby/lib/ruby/1.9/uri/common.rb:176:in `split'"

If I install it in a folder without space in the path then it would work fine

Is there a way to overcome this problem ? it is very urgent thanks


(Mark Walkom) #2

What version are you on?


(Firass Gzayil) #3

The latest
5.1.1
Windows 10


(Firass Gzayil) #4

Any idea?


(Firass Gzayil) #5

After digging in the code, I found the problem
Logstash assumes that the setting dir is relative to the location of the execution folder, and if the execution folder path contains spaces, then it will fail
The bug should be solved; however i found a way to workaround this problem by providing settings path param with escaped value , e.g.

bin\logstash -f c:\ProgramData\Infra\Data\Shipper\Config\shipper.conf --path.settings c:/Program%20Files/Infra/Data/Shipper/logstash-5.1.1/config

or to place logstash configuration in c:\programdata and provide the location using --path.settings


(Mark Walkom) #6

Are you able to raise this as an issue Github please? :slight_smile:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.