Logstash is not generating logs after I include the cmd under container

How can print the logs in logstash, once after I add command and args in container.

containers:
        - name: logstash
          env:
            - name: LOGSTASH_PW
          image: docker.elastic.co/logstash/logstash-oss:7.7.1
          ports:
            - containerPort: 5044
          volumeMounts:
            - name: config-volume
              mountPath: /usr/share/logstash/config
          resources:
            limits:
              memory: 4Gi
              cpu: 2500m
            requests:
              memory: 4Gi
              cpu: 800m
          command: ["/bin/sh"]
          args: ["-c", "cd bin; logstash-plugin install logstash-filter-drop; sleep 1000;"]

it is just printing.

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules to method sun.nio.ch.NativeThread.signal(long)
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Validating logstash-filter-drop
Installing logstash-filter-drop
Installation successful
command: ["/bin/sh"]
args: ["-c", "cd bin; logstash-plugin install logstash-filter-drop; sleep 25; logstash"]

starting logstash after sleep worked for me.

Thanks
Ravi R

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.