Logstash is not outputting read files


I want to use logstash to index some logfiles of mine.

My config, with different paths I have tried:

input {
  file {
    id => "my_files"
	#path => [ "C:\Users\Me\Desktop\files\**\*.log" ]
	#path => [ "C:/Users/Me/Desktop/files/**/*.log" ]
	path => [ "C:\Users\Me\Desktop\files\2019-06-13\11\*.log" ]	

	stdout {}

Please note that I just use stdout to test if something comes through. The output is not the problem. I need help regarding the input.

Can someone please help me? :slight_smile:

is there any error in logstash log file?
does the user has permissions to see this files?
try to use a complete path without "*", if it will work for a single file.

1 Like

I have no errors in the logfile

I started logstash via admin powershell so I can't imagine there being access restrictions.

I did use the absolute path to a single file, still nothing.

Do not use backslash in the path option of a file input. Use forward slash (or double backslash).

1 Like

I tried both to no avail. :confused:

You can increase the level of logging by passing --verbose or even --debug.

Also try to use:

input { 
        file {
                path => "C:/Users/Me/Desktop/files/2019-06-13/11/*.log"
                start_position => "beginning"
                sincedb_path => "NUL"
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.