Logstash Issue while runnig


(Saineshwar Bageri) #1
NameError: cannot link Java class org.logstash.RubyUtil org/logstash/RubyUtil : Unsupported major.minor version 52.0
  method_missing at org/jruby/javasupport/JavaPackage.java:259
      <main> at C:/logstash/logstash-core/lib/logstash-core/logstash-core.rb:37
     require at org/jruby/RubyKernel.java:955
      <main> at C:/logstash/logstash-core/lib/logstash/runner.rb:1
     require at org/jruby/RubyKernel.java:955
      <main> at C:\logstash\lib\bootstrap\environment.rb:66

(Magnus Bäck) #2

Logstash requires Java 8.


(Saineshwar Bageri) #3

hi magnusbaeck,
it already 8 above.

image

i am look for tool to import data from mysql to elastic search, can you guide me in this.


(Magnus Bäck) #4

Okay, but the evidence indicates that Logstash for whatever reason is picking up the wrong JVM.


(Saineshwar Bageri) #5

Sir how can i resolve issue. is Logstash paid.


(Christian Dahlqvist) #6

That looks like a very old Java8 version. The support matrix lists Oracle JVM 1.8u60+ as supported, so it may be worthwhile upgrading Java and see if that helps.


(Saineshwar Bageri) #7

Thanks Christian_Dahlqvist it worked for me.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.