Logstash JDBC input - no suitable driver


(Kevin) #1

Hi All

Does Logstash JDBC plugin ONLY support certain JDBC drivers - and that is fixed in code somehow.

Using an input configuration for Mysql - I get past an error relating to no suitable driver - but I am
trying to use a Progress openedge type 4 jdbc driver (We use same with our Java applications) and
I get no suitable driver.

So the below has the correct type 4 driver jar, correct Class name, correct URL.

It looks like either the plugin does not register the library or does not understand the jdbc_connection_string - regardless of what I do.

So I wondered if the plugin was actually coded to look for only specific types of jdbc URL etc.

e.g.

input {
jdbc {
id => "pro114"
jdbc_connection_string => "jdbc:datadirect:openedge://localhost:1111;databaseName=hr;EncryptionMethod=ssl;validateServerCertificate=true"
jdbc_user => "USER"
jdbc_password => "PASSWORD"
jdbc_driver_library => "/usr/share/logstash/jar/openedge.jar"
jdbc_driver_class => "com.ddtek.jdbc.openedge.OpenEdgeDriver"
#schedule => "*/1 * * * *"
statement => "SELECT * from pub.opgohead;"
}
}


FileMaker jdbc input error
(Rami Atieyeh) #2

I think that might be the case.
I am trying to connect to a different database engine via JDBC, and I am getting the same error.
See: FileMaker jdbc input error


(Kevin) #3

Hi Rami

I have found the issue for Progress but may be applicable to yours.
If you are using a type 4 jdbc driver - put the jar file into the logstash-core/libs/jar/... Folder.

It seems to ignor in the core loading it - however you still need the entry to point to a valid file.

This then registered the driver and I was able to move on.

thanks

Kevin


(Rami Atieyeh) #4

Hi Kevin,
Your solution worked for me.
Thank you!!


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.