Logstash Jdbc Metadata path not creating

Hi,

I have a database and using jdbc plugin to fetch data from it. I have used sql last value and given metadata path it was getting created at first. I deleted and tried to create again but not creating since then. I manually tried to create file and give value but the file is getting deleted on its own.
Also tried clean_run=true but not working.

Following is my code:

    input {

      jdbc {
        clean_run => true
        jdbc_driver_library => "/etc/logstash/sqljdbc_4.2.8112.200_enu/sqljdbc_4.2/enu/jre8/sqljdbc42.jar"
        jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
        jdbc_connection_string => "jdbc:sqlserver://10.9.240.216:1433;database=DB_MB_TAB_CONFIG"
        jdbc_user => "user"
        jdbc_password => "password"
        schedule => "* * * * *"
        statement => "SELECT * FROM TB_ASLG_TXN_DETAIL WHERE create_ts > :sql_last_value"
        use_column_value => true
        tracking_column_type => "timestamp"
        tracking_column => "create_ts"
        last_run_metadata_path => "/etc/logstash/conf.d/metadata/logstash_jdbc_last_run.txt"
        tags => ["sql-uat"]
      }
    }

Regards,
Bryce Fernandes.