Logstash jdbc plugin for mssql crashes


#1

hi,

I have a problem. I try to use jdbc plugin for connecting to a remote MS SQL server. For some reason, the input plugin just crashes/stops without any debugging info. Debugging is configured in the logstash.yml file and other plugins debug nicely.

I have tried with the driver from Microsoft, both versions 6.0 and 4.2, but both produce the same result. I have no idea on what to try next, as I don't get any error messages.

logstash version: 5.6.7

Here the configuration snippet:

input {
      jdbc {
           jdbc_driver_library => "/etc/logstash/driver/sqljdbc_4.2/enu/jre8/sqljdbc42.jar"
           jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
           jdbc_connection_string => "jdbc:sqlserver://myserver:1433;databaseName=mydatabase"
           jdbc_user => "myuser"
           jdbc_password => "mypass"
           jdbc_validate_connection => true
           statement => "SELECT * FROM mytable"
           sql_log_level => "debug"
           schedule => "* * * * *"
           connection_retry_attempts_wait_time => 60
           connection_retry_attempts => 99999999
           jdbc_fetch_size => 50000
           last_run_metadata_path => ".logstash_jdbc_last_run"
  }
}

My java version:

java version "1.8.0_161"
Java(TM) SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)

#2

I noticed an error in the driver file path. So sorry about the unnecessary post - now I get a real error message and can get forward.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.