Logstash LogStash::Error: Don’t know how to handle `Java::JavaLang::IllegalArgumentException` for `PipelineAction::Create<main>`

My logstash was working fine through the Helm chart in Kubernetes stateful set.
I updated the logstash version from 7.9 to 7.16.2 but its don't work so I revert to the previous version 7.9 After reverting it also gives me the error.
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties
warning: thread "Converge PipelineAction::Create" terminated with exception (report_on_exception is true):
LogStash::Error: Don't know how to handle Java::OrgLogstashConfigIr::InvalidIRException for PipelineAction::Create<main>
create at org/logstash/execution/ConvergeResultExt.java:109
add at org/logstash/execution/ConvergeResultExt.java:37
converge_state at /usr/share/logstash/logstash-core/lib/logstash/agent.rb:347

I tried all versions of logstash from 6 to 7.16.2 but got the same error.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.