Logstash lumberjack output kept on using IP instead of hostname

Hello, i currently have a logstash in openshift exposed through openshift route with beats input. I tried to send some logs using powershell with logstash for windows:

bin/logstash -e 'input { generator { count => 5 } } output { lumberjack { codec => json hosts => \"https://hostname\" ssl_certificate => \"lumberjack.cert\" port => 443 } }' --path.data .\data2

but i got ssl verify failed:

[2023-09-07T10:13:56,242][ERROR][logstash.outputs.lumberjack][main] All hosts unavailable, sleeping {:hosts=>[""], :e=>#<OpenSSL::SSL::SSLError: certificate verify failed>, 

Openshift routes uses hostname for redirecting to services, but lumberjack uses IP in the hosts section in the error code. I have tried using 2 certificates, 1 with IP common name, and 1 with service as common name (not route). I included the openshift route url and ip in the SAN. Here is my beats input in openshift:

input {
        beats {
          port => 5044
          ssl => true 
          ssl_certificate => "/tmp/lumberjack-cert/lumberjack.cert" 
          ssl_key => "/tmp/lumberjack-cert/lumberjack.key"

Logstash in openshift is at version 7.6.2 while windows is in 8.9.1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.