[Logstash monitoring with metricbeat]: http server gave http response to HTTPs client

Hello,

I am trying to monitor my cluster using metricbeat, for elasticsearch and kibana nodes it's working perfectly, but when I try to monitor logstash I am getting these errors from my metricbeat logs

2020-12-31T11:05:15.788+0100	ERROR	[logstash.node]	node/node.go:79	could not fetch node pipelines: error making http request: Get "https://10.13.81.40:9600/_node/pipelines?graph=true": http: server gave HTTP response to HTTPS client
2020-12-31T11:05:15.789+0100	ERROR	[logstash.node_stats]	node_stats/node_stats.go:73	error making http request: Get "https://10.13.81.40:9600/": http: server gave HTTP response to HTTPS client
2020-12-31T11:05:25.789+0100	ERROR	[logstash.node_stats]	node_stats/node_stats.go:73	error making http request: Get "https://10.13.81.40:9600/": http: server gave HTTP response to HTTPS client
2020-12-31T11:05:25.797+0100	ERROR	[logstash.node]	node/node.go:79	could not fetch node pipelines: error making http request: Get "https://10.13.81.40:9600/_node/pipelines?graph=true": http: server gave HTTP response to HTTPS client
2020-12-31T11:05:35.787+0100	ERROR	[logstash.node]	node/node.go:79	could not fetch node pipelines: error making http request: Get "https://10.13.81.40:9600/_node/pipelines?graph=true": http: server gave HTTP response to HTTPS client
2020-12-31T11:05:35.789+0100	ERROR	[logstash.node_stats]	node_stats/node_stats.go:73	error making http request: Get "https://10.13.81.40:9600/": http: server gave HTTP response to HTTPS client

Here is my configuration:

Logsatsh.yml:

node.name: VSELK-LOGSTASH
path.data: /var/lib/logstash
pipeline.ordered: auto
config.reload.automatic: true
http.enabled: true
http.host: 10.13.81.40
http.port: 9600
path.logs: /var/log/logstash
monitoring.enabled: false

logstash-xpack.yml:

- module: logstash
  xpack.enabled: true
  period: 10s
  hosts: ["https://10.13.81.40:9600"]
  username: "remote_monitoring_user"
  password: "PASSWORD"
  ssl.certificate_authorities: ["/etc/metricbeat/certs/ca.crt"]
  ssl.certificate: "/etc/metricbeat/certs/VSELK-LOGSTASH-KIBANA.crt"
  ssl.key: "/etc/metricbeat/certs/VSELK-LOGSTASH-KIBANA.key"
  ssl.verification_mode: "full"

could you tell me please how can I solve this problem ? and how can I set the logstash to use https to respond to the client

Thanks for your help