Logstash not listening

2020-09-21T11:01:30.174+0530 INFO cfgfile/reload.go:224 Loading of config files completed.
2020-09-21T11:01:31.181+0530 INFO [publisher_pipeline_output] pipeline/output.go:143 Connecting to backoff(async(tcp://localhost:5044))
2020-09-21T11:01:31.181+0530 INFO [publisher] pipeline/retry.go:219 retryer: send unwait signal to consumer
2020-09-21T11:01:31.183+0530 INFO [publisher] pipeline/retry.go:223 done
2020-09-21T11:01:36.598+0530 ERROR [publisher_pipeline_output] pipeline/output.go:154 Failed to connect to backoff(async(tcp://localhost:5044)): dial tcp [::1]:5044: connectex: No connection could be made because the target machine actively refused it.
2020-09-21T11:01:36.598+0530 INFO [publisher_pipeline_output] pipeline/output.go:145 Attempting to reconnect to backoff(async(tcp://localhost:5044)) with 1 reconnect attempt(s)

Logstash is not listening.


============================== Filebeat inputs ===============================


Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • type: log

    enabled: true


    • C:/Users/cnk/Desktop/Logs/StVincents_FullLogs/20191009-111056/new_logs/SummaryErrorByFrequencyLog/*

------------------------------ Logstash Output -------------------------------


The Logstash hosts

hosts: ["localhost:5044"]

Optional SSL. By default is off.

List of root certificates for HTTPS server verifications

#ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"


input {
beats {
port => 5044

output {
elasticsearch {
hosts => ["http://localhost:9200"]
index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
#user => "elastic"
#password => "changeme"

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.