Logstash not reading CSV file when running as CSV


I am trying to run ELK through service on windows, Kibana and Elasticsearch is working fine as service.

I have configured service through nssm and used below reference to configure logstash

Logstash starting properly but not reading the CSV file. i tried with every possible way to resolve but failed. I tried with UNC path i gives me below error

[2020-11-12T18:53:14,328][WARN ][filewatch.tailmode.handlers.create][main][6c67464455f07920dd2f946303d7ab774f31461750881a09a01135cc62cdb4fc] failed to open //server/Link2/DataFileLogstash/XDViews/TotatOrderOfDay.csv: java.nio.file.AccessDeniedException: \server\Link2\DataFileLogstash\XDViews\TotatOrderOfDay.csv, ["sun.nio.fs.WindowsException.translateToIOException(WindowsException.java:83)", "sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:97)", "sun.nio.fs.WindowsException.rethrowAsIOException(WindowsException.java:102)"]

But when i changed the path to read CSV file then it's not reading the file. but now there is no exception showing in logs.

input {

file {

path => "D:/ELK/logstash-7.9.3/config/*.csv"
#path => "//server/Link2/DataFileLogstash/XDViews/TotatOrderOfDay.csv"
#path => "Q:/DataFileLogstash/XDViews/TotatOrderOfDay.csv"

start_position => "beginning"
#sincedb_path => "//server/Link2/DataFileLogstash/logstash.db"
#stat_interval => 1
#discover_interval => 1
#sincedb_path => "NULL"

Please help, Any solution ?

Set log.level to TRACE, then the filewatch module that the file input uses will log messages like these to tell you what it is doing.

On Windows, if you want to disable the persistence of the in-memory sincedb across restarts then you would use sincedb_path => "NUL", not NULL.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.